本バージョンについて


grwnd.exe を含む本ライブラリは未だ開発中ですが,Version 0.99.9b はβ版であり,仕様は最初の正式公開版 1.00.X とほぼ同じ予定です。 マニュアルの不備も予想されますし,まだ思わぬ問題が存在するかもしれませんので, お気づきの点をメーリングリストに報告していただければ幸いです。

今後バージョンアップが行われた場合には,ライブラリと grwnd.exe のバージョン(README.txtに記載されているものと,メニューバーの [ヘルプ] -> [grwnd について] で確認)が一致していること確認する必要があります。 ライブラリのバージョンと,適合する grwnd.exe のバージョンは,プログラムで GWVERSION を呼び出すことによっても調べることができます. 古いライブラリで作成されたアプリケーションは新しい grwnd.exe では動かないと思ったほうが良いでしょう(その逆も)。

実行ファイルにリンクした GrWin ライブラリと grwnd.exe のバージョンが一致していない場合には,

"WARNING: XXX [x,x,x,x] is older than YYY [y,y,y,y]"
のような,どちらが古いかを示す警告メッセージがコンソール・ウィンドウ(CUI)に表示されますので,両者のバージョンを一致させて下さい。 なお,[ ] 内の数字(またはアルファベット)がそれぞれのバージョンを表わしています。 最新版は http://spdg1.sci.shizuoka.ac.jp/grwinlib/ から入手することができます

配布ファイル中のユーティリティー f77chk を利用すれば,Fortran のソースコードが現在のバージョンに適合しているかどうかを調べることができます。



Tsuguhiro TAMARIBUCHI <tamari@spdg1.sci.shizuoka.ac.jp>

Last modified:  Tue Jun 10 22:59:58 JST 2003